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Design Statements

This process control equipment to be supplied by Class2, LPS, limited power supply. 
EMC Standard, EN 61326-1: 2006, Electrical Equipment for Measurement, Control and 

Laboratory Use. 
	 Emissions Class A, Commercial Equipment. 
	 Immunity Table 2, Industrial Equipment. 

LVD Standards, EN 61010-1: 2010, Safety Requirements for Electrical Equipment for 
Measurement, Control and Laboratory Use and;  

	 EN 61010-2-030: Particular Requirements for Testing and Measuring Circuits. 
smarty is an industrial controller designed for permanent installation by qualified professionals. 

If  it is used in a manner not specified herein the protection provided may be impaired. 
smarty and its packaging contain recyclable materials 

This device is designed to comply with Part 15 of  the FCC Rules. Operation is subject to the following two 
conditions: (1)This device may not cause harmful interference, and (2)this device must accept any interference 
received, including interference that may cause undesired operation. 

This Class [A] digital apparatus is designed to comply with Canadian ICES-003.  Cet appareil numerique de la 
classe [A] est conforme à la norme NMB-003 du Canada. 

Warning! It is essential that you read and understand this entire manual and the entire contents of  the savvy 
software Help menu before proceeding with your installation and configuration. See page 6 for savvy installation 
instructions. For more information and to download manuals and software, go to www.driveweb.com or contact 
us. See page 12. 

Warning! Your use of  savvy software and drive.web devices may cause motors and machinery to power up 
with high Voltages or start or operate in an unexpected, dangerous or lethal way. It is essential that you are 
completely familiar with all of  the equipment and the system design before attempting to program or edit a 
program or connect to any live device. It is also essential that a risk assessment is conducted to identify hazards. 
Risks must be reduced to tolerable levels. 

Warning! You are entirely responsible for the configuration or use of  any drive.web product. By configuring 
or using these products you agree to indemnify and hold harmless Bardac Corporation, its employees, directors, 
officers, distributors, and resellers against the consequences of  your configuration or use of  the products. 

Warning! Information in this manual is subject to change without notice. You are responsible for verifying the 
proper operation of  your smarty. Special care must be taken after loading new firmware or installing new options.  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Warning! Avoid permanent damage to your smarty, never exceed any min or max values.  Do not connect 
any smarty terminal to mains circuits. See page 5 for IO ratings. 
lwIP is incorporated into smarty firmware. lwIP Copyright (c) 2001-2004 Swedish Institute of  Computer Science. All rights reserved. 
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: 
1. Redistributions of  source code must retain the above copyright notice, this list of  conditions and the following disclaimer. 
2. Redistributions in binary form must reproduce the above copyright notice, this list of  conditions and the following disclaimer in the documentation and/or 
other materials provided with the distribution. 
3. The name of  the author may not be used to endorse or promote products derived from this software without specific prior written permission. 
THIS SOFTWARE IS PROVIDED BY THE AUTHOR “AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT 
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN 
NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL 
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR 
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT 
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN 
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 

Product Identification - smarty7

The smarty7 dw25x Series are Universal Automation Controllers (UAC) 
Find smarty model and firmware version. Use savvy, Get Detailed 

Info from smarty contextual menu. See page 6.  

Product Identification - Part Numbers
Model number dw25x is appended with a three character extension. 

   Example; dw250-DM-S7PF

	 	 	 	 	 	 	 	 Model		 	 ModbusRTU Type		 	 	 Terminal Type	 	 	 	 	 	 	 	  
	 	 	 	 	 	 	 	 Build Standard	 	 	 	 	 	 XIO Build (2 characters)		 Mounting		 	 	  

smarty7 Models 
dw250 Universal Automation Controller, (UAC). 
dw254 UAC for P2  industrial vector drive. 
dw258 UAC for E3 open-loop vector drive. 
dw259 UAC for CANopen server devices. 

Build Standard A, B, C, and D - Software Options  
A=04 and 26, B adds 05 and 25, C adds 06 and 39, D adds 10 and 29. 
04 ModbusTCP/IP - Server-slave. See page 12. 
05 Process Control - Recommended for most applications. 
06 Winder Control - Diameter Calc., Taper Tension, Torque Comp. 
10 Math - With advanced math functions.  
25 EIP/PCCC - Slave/server. See page 12. 
26 savvyPanel - Operator station interface. See pages 8, 9. 
29 Solar - Calculates sun position azimuth and zenith. 
39 Precision Motion - With event, length, position, shaft-lock,  

indexing, motion control, cam profile, and more. Page 12. 

ModbusRTU Type, Options M, S, X 
M - ModbusRTU Client-Master with speeds up  to 500kbps. See page 12 
S - ModbusRTU Server-Slave. Read or write any parameter in the 

device remotely. See page 12. 
X - No ModbusRTU capability.  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XIO Build S7, HV, CL, XD, XA 
S7 - Standard, no XIO option installed. 
HV - Ten Digital Inputs, presets for 24VAC, 120VAC, or 240VAC. 

Six Digital Outputs, 24VAC to 240VAC, 0.5A with ZVS. 
CL - Sixteen 4-20mA inputs. 

Eight 4-20mA outputs. 
Eight digital out/in, separate source up to 24VDC, 300mA shared. 

XD - Sixteen digital inputs, 3V to 30V logic with 5V and 24V enumeration. 
Sixteen digital outputs/inputs, separate source up to 24VDC, two 
300mA shared banks. 

XA - Four separately-isolated, milliVolt analog inputs w/ 5V excitation and 
cold-junction compensation for load-cell, thermocouples, RTDs, 2V max. 

Terminal Type P 
P - Plug-in screw terminals; six blocks of  10 terminals; 60 total. See page 4. 
Mounting D, S, F, A, 4 
D - DIN rail edge mounting without flex clip. 
S - DIN rail side, flat mounting using standard clips. 
F - Flex mounting; DIN rail edge or DIN rail flat with flex clip. 
A- Spacer mounting with four bolt holes, see page 5. 
4 - NEMA4X enclosed. 
smarty7 Installation
smarty is designed for permanent installation by qualified professionals.
Install smarty in metal enclosure with no RF noise source. 
DIN rail mounting - Use 35x7.5mm rail per IEC 60715 or EN50022. 
Environment - UL/IEC Pollution Degree 2. 

Operating temperature, 0°C min., 50°C max.  
Storage temperature, -20°C to 50°C. 
Altitude 3000m max.  
Humidity 95% max. non-condensing.  

Clearances must be provided all around to promote airflow, 5mm (0.2”) sides, 
25mm (1”) above and below. 

smarty7 Terminal Naming and Ratings
Terminal names are consistent in the drive.web savvy software, on 

the terminal, and on the cover plate next to the terminal.  
24VDC and 0V Terminals are internally connected. 

Regulated DC Supply, 25.2Vmax, 22.8Vmin, 1A.  
External 1A fast-acting fuse or current-limiting is required!  
Do not connect to a distributed DC power network.  
Supply from Class 2, LPS, limited power supply, from 

within the same electrical enclosure, only. 
AI - Analog inputs. -11VDC to +11VDC, 100kΩ, 1kHz, 16-bit. Also 

configurable for 5V or 24V logic digital input. 30V max. 
AO - Analog outputs. Bipolar, -10.5VDC to +10.5VDC. 10mA. 
DI - Digital inputs. 50VDCmax, 8VDC threshold, 3V hysteresis. 1kHz. 

Configurable as event inputs. 
DO - Digital outputs. 24VDC source, up to 300mA, shared. 

Resistive, general use, and pilot duty. Overcurrent protection 
and software indication. Also configurable as digital inputs. 
Maximum Voltage is 25.2VDC. 
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smarty Terminal Naming and Ratings (continued)
1A+ - Example: Encoder 1 Channel A+. Differential or single-

ended, incremental, quadrature encoder input. 24VDC max, 
-0.5VDC min., Up to 1MHz. 2A and 2B can be configured as 
marker inputs. 

FT - Frequency, timing, event, stepper, or digital input and output. 30Vmax. 
	 Use FI function blocks for inputs 100kHz. Configurable for 24V 

logic or 5V logic with pull-up or pull-down. Configurable for 
frequency, counter, event, or digital input. 

	 Use TO function blocks for outputs. Configurable for stepper, 
frequency, or digital sinking output. 20mA, 500kHz max. 

TO7 - Same as FT TO above but also configurable as a digital input 
and a unipolar analog input with settable range. 

+5V Power supply output for use with encoders, sensors, etc, 250mA max.  

smarty Terminal Wiring
Strip 7mm(0.28”). 1.5mm2 (AWG16) max. One wire with 

ferrule, 0.8mm2 (AWG18) maximum. 
Use shielded cable for runs over 30 meters. 
Fast transient over-Voltage 1kV per EN 61000-4-4. 
Signal Wiring Notes  
Use twisted-pair wiring for encoder and serial differential signals.  

Outside metal enclosure, use shielded cable with individually 
shielded twisted-pairs such as Belden 8163. Ground 
shield at one end with a 360° ground clamp where cable 
enters “quiet” metal enclosure.  

Separate wiring from AC power cables or RF noise sources. 

smarty7 Front Panel
USB port  - USB-C jack. Full/high speed. Can be used 

for backup power to maintain the real-time clock.  
Ethernet port - MDI 8P8C, “RJ45” jack, 100baseTX and 

10BaseT, Full Duplex, Auto Negotiation, Auto-MDIX, IEEE 
802.3ab.  

Indicator LEDs in front panel:  
Status - Blue LED. Status heartbeat pulses twice a second. 
Fault - Red LED indicates a fault. Check power supply, 

connect with savvy, or contact us at drive.web for 
more info. 

Ethernet link/activity - Orange LED indicates Ethernet 
connection and blinks for activity. 

100BaseTX - Green LED when connection is 100BaseTX. 
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smarty7 DRIVE Serial Port
AMPMODU 104257-4 socket marked ‘10101’ 

ModbusRTU EIA485. Optional cable assembly, LA504452, required. 

dw254 and dw258 include 1m cable assembly, LA504451, for 
CANbus connection to P2 and E3 drives.  

dw259. Includes 1m cable assembly, LA504452. Do not add 
termination resistors for CANbus. These are built-in. 

smarty7 Dimensions, Overview, and Terminal Map

	 	              	  

	 	         

Spacer Panel Mount Option -A
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smarty Real-time Clock
The real-time clock is only used for time of  day and 

calendar functions. It can be set automatically by PTP to 
other drive.web devices, automatically upon discovery in 
the drive.web savvy software, per preferences, or via  
SNTP network time server protocol. See the savvy user 
manual for details.  

The real-time clock will be maintained for approximately 
24hrs after supply power loss with no backup battery. 
Alternatively the clock can be powered by the USB port.

Lithium button cell battery, CR2032, 3VDC, commonly 
found in convenience stores, is not provided from the 
factory due to shipping restrictions.

smarty7 Frequency Input Notes (FI Terminals)
FI Digital and Event Input Function Blocks

Maximum event frequency is 1/(2*FBE cycle (s)) Hz. E.g., 
for 5ms FBE cycle, the max event frequency is 1/10ms = 
100Hz. 

Use Digital Input function block Input Type parameter to 
configure; 

FI Counter Inputs - Provide frequency data with adjustable 
moving-average filter and count outputs for use with 
motion control function blocks. 

FI Frequency Inputs - Useful for lower frequencies 
~<10kHz. Duty cycle is also measured. Updates every 
FBE cycle or two-edge cycle.  

FI Input 
Type

Threshold 
VDC

Threshold 
Min. VDC

Threshold 
Max. VDC

5V Logic 
with pull-
down

2.0 1.0 3.0

5V Logic 
with pull-up 1.4 0.4 2.4

5V Logic 1.7 1.0 2.4
24V Logic 
with pull-
down

8.4 5.0 11.8
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smarty Programming 
Set up your computer - Get savvy 
With free drive.web savvy software, easily program and 

monitor your smarty, perform data trending, and create 
distributed control systems. 

Go to www.driveweb.com and click on Get savvy, or 
contact us to get the latest version of  savvy. 

smarty USB - Plug and Play 
Plug-and-play access to smarty and its local Ethernet 

network. 

smarty Ethernet Networking & Programming 
Assigning an invalid or duplicate IP address will cause serious 

network malfunctions!  
Find useful networking information. Under the Help menu 

click on Getting Started with savvy section.  
smartys are shipped with an IP address, 10.189.x.x, 

derived from the serial number. The six-octet serial 
number always starts with 0-4-bb-x. The last two octets 
are used to assign the as-shipped IP address; Example, if  
the serial number is 0-4-bb-00-1a-2b, 1a is converted from 
hexadecimal to decimal, 26. 2b, similarly, is 43, decimal. 
The as-shipped address is 10.189.26.43. 

Use Category 5e cable or better, with 8P8C/RJ-45 connectors 
for each drive.web  device and the host computer. 

For systems with more than one drive.web device, use an 
Ethernet switch for all drive.web devices and computer. 

Get started with savvy 
We strongly recommend attending our free online 

training seminars. See page 12. 
We strongly recommend you read the User Manual 

and Getting Started Guides under the Help menu.    
Use Create Phantom in the Directory menu to 

explore drive.web products and options, design, 
and configure offline. Export Data to save your 
work. Import Data into  phantoms to work offline.  

savvy Window Title Bar indicates the current view. 

Status Bar, above the viewing area, provides Navigation 
Arrows and object and location data. 
savvy views are hierarchical with the Device Directory 
View at top. Use the Navigation Arrows to go up, back, 
or forward. Window menus change as you navigate.  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Hover cursor over active object, device, function block, 
connection, or parameter icon to view object information 
in the Status Bar and reveal a Hover Button. 

Click a Hover Button or right-click an active object to 
access a Contextual Menu. See below. 

savvy functions are limited by password-protected 
capability level. See File > Capability… 

Device Directory Window  

Warning! Changing a device IP address WILL disrupt its 
network connections! If  a smarty is communicating with 
other devices, be prepared for system disruption. In the 
File menu choose Utility > Remap Export File to 
remap a dw-system file with different IP address(es). 

Select File>Administrate>Set IP Addresses for 
System.   

smarty serial number is also its MAC Address.  
Enter a valid IP address and click OK.   

An icon appears with IP address beneath. Drive-dedicated 
models depict the actual frame size of  the drive. 

If  the icon at right appears, a network connection problem 
exists. Check connections, LEDs, and that the smarty  
IP address is within the computer’s Ethernet subnet mask.   

Warning! Importing data into your smarty will result in 
immediate execution of  that configuration. Dangerous 
Voltages and rotating machinery may result! Use 
a phantom to preview a configuration. 

Directory > Import / Export Data. All device configurations 
and connections in the directory in one .dw-system file.  

smarty Icon Contextual Menu  
Change Name - Name your smarty for easy identification.  
Import / Export Device Data... - Load / save configuration 

data to / from this smarty only. 

Unlock, Lock, Set Password - Choose Restrict 
Modification to allow viewing the configuration, or 
Restrict All Access. 

Click the smarty icon to view the device configuration. 

Function Block Engine Window - FBE Menu 
(Standard savvy, no SFD) 

Add function blocks in the order to be processed. Processing 
order is left to right, top to bottom. 

Click function blocks to view parameters and details.  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Connect between parameters and other drive.web devices.  

Warning! Making a connection results in immediate 
execution of  that connection. Dangerous Voltages and 
rotating machinery may result! 

Under the File menu, choose New Viewer... and then, 
File > Open Device Directory.  

With two viewer windows, click a parameter, drag and 
drop onto a parameter in the other viewer.    

Parameter Contextual Menu - Data is formatted, limited, 
and scaled depending on the parameter. Use Get Info or 
Re-Scale... to verify or change. 

Click parameters for the Setter Box - Increment, 
decrement, default, last state, or keyboard entry. 

Click blue connection block or arrow to jump to other end. 

Upgrade savvy and smarty 
Upgrade savvy with SFD Signal Flow Diagram.  

Upgrade smarty with software options.  

Process credit cards or Vouchers online or Coupons offline.  

To upgrade savvy, go to the Commerce menu, select 
Upgrade savvy, check desired options, click OK. 

To upgrade smarty, choose Upgrade Device… in its 
contextual menu, check desired options, click OK. 

To process Vouchers, choose Pay > Online Via Vouchers 
in the Shopping Cart. Enter Voucher codes on separate 
lines. 

To process Coupons, go to the Commerce menu and 
choose Coupon Manager. Enter codes in the top box 
and click the Add button and the coupon is recognized. 
Click Apply. 

savvy-SFD Signal Flow Diagram Upgrade 
With savvy-SFD, build systems graphically. The live 

drawings are stored in your smarty.   

Set drawing borders and annotate multi-page drawings.  

A filterable list of  function blocks and connections is at the 
left of  the Signal Flow Diagram showing program 
execution order from top down. Change execution 
order by dragging function blocks up or down the list. In 
this picture, ENC1 Speed function block is moved so that 
it is processed after ENC Phase Lock. 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savvyPanel Operator Station
Computers, Apple®, and Android™ mobile digital devices 

are operator touch stations with savvyPanel. Requires 
Windows, Mac OS X, Linux-based Ubuntu, Android, 
or iOS®. 

Configurations are stored in the drive.web devices. 

savvy-SFD upgrade is required to edit or build 
savvyPanel systems. 

dwOption-26 savvyPanel, must be installed in 
drive.web devices to enable the full suite of  tiles. A 
limited set is available without the option.  

Get savvyPanel free from Apple App Store℠ and Google Play

When your mobile digital device is connected to the 
internet via WiFi, demo mode connects to a live drive 
system in our plant in Maryland, USA. 

Explore the demo with savvy. Select File > Demo Mode > 
Discover Internet Demo DevicessavvyPanel Pages

Systems Page where multiple savvyPanel systems are present.  

A savvyPanel system may contain tiles from many drive.web devices.  

A drive.web device contributes to only one savvyPanel system. 

Touch the systems button,      or     , in the window bar to 
access the systems page from home page. Lock this button 
with home password. 

Home Page is the first operator page in a savvyPanel system. 

Access home page from any operator page with the home 
button,      . Lock with the home password. 

Operator Pages show graphic, page-link, and parameter tiles.  

Pages can be renamed. Page name appears in window title bar. 
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savvyPanel Tiles
Parameter Tiles - Touch a settable parameter to set. Setter 

includes slider, keypad, 1x and 10x increment and 
decrement, return-to-default, and revert.  

Graphic Tiles - Create diagrams with process elements. 
Page-Link Tiles - A graphic tile that is also a page-link.  

Touch to change the view to that page.
Device Tiles - Link to device’s signal flow diagram in Java-

based savvyPanel. Appears as graphic tile in iOS. 
Function blocks enable savvyPanel actions

Alarm Annunciator - Provides a system-wide alarm 
annunciation when active. Touch to view page 255. 

Presence Monitor - Indicates the presence of  a tagged 
savvyPanel application viewing a particular page. 

Latch and SR Latch - For lighted start-stop pushbuttons.  
Setpoint & Monitor - Adjust meter and setter range. Dual 

blocks enable dual-display meters. 
Enumerated Parameter - In Utility group. Only custom 

enumerations appear in the setter and multi-position switch. 

savvyPanel Launch, Setup, and Important Notes
See the savvy user manual for detailed instructions. 
Launch savvyPanel via command line or batch file.  
Limit operators to savvyPanel only. Specify start system and page. 
Discover devices automatically, specifically by discovery file, 

or filtered by group and/or savvyPanel name. 
Operator’s note: If  communication with a drive.web 

device is interrupted, affected tiles indicate a yellow bar 
with a warning symbol. The tile is not updated. 

Important Design Note - An over-range enumeration is 
required if  an out-of-range value could cause a hazard. 

smarty Precision Motion Parameters, Connections
Special parameter and connection types from I/O function blocks. 

Connections may also be over Ethernet to other drive.web 
devices without performance penalty.  
Floating Point - IEEE-754 Binary32, wider range and 

resolution. Can be connected to or from standard, 16-bit 
parameters; 1.0000 float equals 100.00%. 

Event - Events are associated with exact count values. 
Maximum event frequency is (1/(FBE Timebase seconds)) 
Hz. Only the first event is processed per FBE cycle. 

Count - Position applications; shaft-lock, registration, motion 
control, etc. 64-bit internal values, precision timing data.  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smarty Comms Interfaces-CANopen, Modbus, EIP/PCCC
Warning! Use of  smarty comms interfaces may cause 
motors and machinery to energize with high Voltages, or start, 
or operate in unexpected, dangerous, or lethal ways. 

For Modbus specs go to http://modbus.org/specs.php 

smarty Comms Server dwOption-04 and -25 
Note! You cannot write or force parameters that are read-only or 

have incoming drive.web connections. 
Click the Comms Server icon in the FBE or SFD view. 

dwOption-04 ModbusTCP/IP slave/server
Supported Modbus Function Codes; 1 thru 6, 15, and 16. 
Supports up to five simultaneous clients/masters.  

dwOption-25 EIP/PCCC Server
Supports PLC5 Typed-Write and Typed-Read commands. 
See Appendix B of  the savvy User Manual for information and 

drive.web parameter IDs mapping to PLC5. 
Supports up to two simultaneous clients. 

ModbusRTU
M=Master-Client, S=Slave-Server, X=None. See pages 2 and 4.

Modbus Function Codes FC 01 through 06 and 16 are 
supported. Also special Yaskawa Holding Register. 

Each server’s Modbus address must be unique on the network!  
All devices on the network must have the same baud rate, up to 

500.0kbps, and the same character framing.

dw259 Generic CANopen Master 
Dedicated to a single server device at speeds up to 1Mbps. 
1m max cable length.  
Do not use termination resistors. These are built-in. 
Use CANopen Setup function block to configure. 

drive.web Training Courses  
Free online interactive training seminars take about one hour.  
Specialized online and factory training sessions are also 

available.  
To register email training@driveweb.com or call.
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Ph. 410-604-3400, Fax 410-604-3500, www.driveweb.com
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